Transcription service unavailable
Incident Report for Tropo
Resolved
Our vendor reports service has been restored.
Posted 7 months ago. Feb 07, 2017 - 16:28 EST
Investigating
Transcription services are unavailable due to a vendor outage. The issue is being investigated.
Posted 7 months ago. Feb 07, 2017 - 15:08 EST